www.8devices.com
View unanswered posts | View active topics It is currently 24 Jan 2018, 07:42



Reply to topic  [ 4 posts ] 
 USB2can Issues with one car 
Author Message

Joined: 03 Jan 2018, 15:46
Posts: 4
Hi All,

First post....

I'm having issues sniffing the CAN BUS on a 2017 Skoda, the device is returning all the same data, I tested it on a 2013 kia and it worked perfectly! I have the correct OBD cable and detailed on the forum as previously no data was being returned.

Is it possible that the can bus is hidden from the OBD port on the skoda?

I've tried bitrates of 500k, 250k, and 125k all with the same results. Any ideas/suggestions on what I could do differently?

I've added the screenshots for information.

Thanks in advance

***EDIT*** I have since discovered that this could be due to the can gateway on VAG cars, any idea how to sniff the traffic and get around the gateway?


Attachments:
File comment: 2013 kia
Screenshot from 2018-01-03 15-15-02.png
Screenshot from 2018-01-03 15-15-02.png [ 60.82 KiB | Viewed 96 times ]
File comment: 2017 data
Screenshot from 2018-01-03 15-04-11.png
Screenshot from 2018-01-03 15-04-11.png [ 33.94 KiB | Viewed 96 times ]
03 Jan 2018, 15:52
Profile
Online
8devices
8devices

Joined: 07 Dec 2011, 16:01
Posts: 501
Location: Lithuania
Hi,
can you try to read data running in Windows mode ? (canal driver).
Linux driver has a bug in high speed data mode.

Did you try the other manufacturer converter ?
Bad thing that I don't have similar can so I can't check.
What is the Kia can bus speed ?



Is it yours post:
http://jas-hacks.blogspot.lt/2017/01/im ... hicle.html

nulleight15 May 2017 at 16:34
Hi, thanks, I got it working at 500kBps. Do I understand correctly, that I now have to open communication channel using VW TP 2.0 before I see anything? For now I only see one strange message repeated indefinitely:
0x17F00010 with data bytes 20 10 00 00 00 00 00 10

Thanks for your answer,
Konstantin


22 Jan 2018, 17:34
Profile

Joined: 03 Jan 2018, 15:46
Posts: 4
Hi,

No that wasn’t my post although looks like the same issue.

I haven’t tried it on windows yet, however I also have the CANtact which gives the same issues on the skoda yet reads it on the Kia, both speeds weee set to 500 however I’ve tried the skoda on all the main ones.

The only time I’ve had any data returned was when I connected the usb2can via a Y cable to a vcds and looked at the data being sent to the vcds, however it still did not give me anything useful. I’ll try windows tomorrow but not holding much hope.


22 Jan 2018, 22:14
Profile

Joined: 03 Jan 2018, 15:46
Posts: 4
So a bit more digging.

Tried it today with windows no change, tried it in conjunctiok with Kayak = no change.

The VAG obd port will only send data which is requested by an approved (with a handshake), looks like candy no and cansniffer are totally no goes. Basically short of tapping into the wiring prior to the can gateway module I think I’m “totally” outa luck.


23 Jan 2018, 19:49
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.